Support of Ruby 2.4 has ended

7 months ago - Direct link

We announce that all support of the Ruby 2.4 series has ended.

From the end of March of the last year, the support of the Ruby 2.4 series
was in the security maintenance phase.
Now, after one year has passed, this phase has ended.
Therefore, at March 31, 2020, all support of the Ruby 2.4 series has ended.
Bug and security fixes from more recent Ruby versions will no longer be
backported to 2.4, and no further patch release of 2.4 will be released.
We released Ruby 2.4.10 at March 31, 2020, but it was to give users a little
time to move to newer versions.
We highly recommend that you upgrade to newer versions of Ruby as soon as
possible.

About currently supported Ruby versions

Ruby 2.7 series

Currently in normal maintenance phase.
We will backport bug fixes and release with the fixes whenever necessary.
And, if a critical security issue is found, we will release an urgent fix
for it.

Ruby 2.6 series

Currently in normal maintenance phase.
We will backport bug fixes and release with the fixes whenever necessary.
And, if a critical security issue is found, we will release an urgent fix
for it.

Ruby 2.5 series

Currently in security maintenance phase.
We will never backport any bug fixes to 2.5 except security fixes.
If a critical security issue is found, we will release an urgent fix for it.
We are planning to end the support of the Ruby 2.5 series at the end of
March 2021.

Posted by usa on 5 Apr 2020


Go to article →